At least one instance of PC*MILER|TCP/IP must be running before you can start PC*MILER-AS/400 Multi-Version Switch (as400.exe). AS400.exe while running maintains a list of available PC*MILER versions. It will find a newly started instance of PC*MILER|TCP/IP and will remove a version that has stopped responding.


If you edit StartMvs.bat and create a shortcut for it in your startup folder, the software you installed on your dedicated PC will cause the interface to start automatically when the PC is turned on.  If Client Access Express is running on the PC, then click on the PC*MILER AS/400 icon or reboot the PC. Client Access Express must automatically sign on with a user ID and password, if unattended startups of the mileage server PC are desired. 


When the mileage server (as400.exe) starts, it displays the connection status in the mileage server’s log window.  You can bring up this window by clicking on the mileage server’s Window menu and choosing Display Server Log.



The Name of Mileage Request or Input data queue, and the library in which the queue resides, are logged. The number underneath the data queue name and library is the connection status return code. Good returns are:


0 Connection Good Created Data Queue

2 Connection Good Found Data Queue


Return codes of 1 or 3 are generic error codes that indicate problems with your Client Access Express connections.


NOTE:  Both the PC and the AS/400 must agree on the location of the Input or Request data queue. To change the location on the PC, click on the mileage server’s File menu. Choose AS/400 Control, then Change Library/Queue. The change is made on the AS/400 by running the ALKMVS/mvsfig or ALKMTL/mtlfig command and filling out the library field.


The server log only notes incoming requests. If you need to see the mileage server’s outputs, turn on the Log to File feature by selecting the mileage server’s File menu and choosing AS400 Control > Highlight Log to File and choose Append, Overwrite, or Verbose. This will create a file called c:\ALKMVS\as400.log or C:\Alktoll\as400.log


It is recommended to only use logging for diagnostic purposes, otherwise the log files tend to grow large. Append will add to the existing log file, Overwrite will delete the current log file, and Verbose will append to the existing log file and contains PC-to-AS/400 communication messaging.